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 1 Introduction
Thanks for purchasing the ECU+ fuel and timing computer. The ECU+ is an inexpensive,
compact, full-featured piggyback computer that modifies the MAS airflow and the cam and
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crank angle sensor signals on your 1990-1999 4G63-equipped turbo Eclipse, Talon, Laser or
Galant VR-4, or 2003-2005 Lancer Evolution, giving you complete control over fuel delivery
and timing of your vehicle.  The ECU+ is typically used on high-performance vehicles with
larger turbos, upgraded exhausts and higher-flow injectors to fine-tune your vehicle's
performance.

The ECU+ can modify the fuel and timing of your engine at some 33 "points," depending on
the engine's air flow, RPM and throttle position.  In addition, the ECU+ supports full
datalogging of most engine sensors at 25 samples per second.  Datalogged information can
be viewed and analyzed with the included Palm OS or Windows software.

 2 Warning
The ECU+ system is an sophisticated device intended for off-road use, and is not in any way
certified for use on public streets.  The ECU+ provides you with the ability to adjust the
air/fuel and timing mixture of the engine in your car.  If used improperly, the ECU+ can
destroy your engine.  Neither the dealer nor the manufacturer of the ECU+ may be held
responsible for any damage to your vehicle as a result of the installation, use or misuse of
this product.  Additionally, you should never adjust your engine's settings or attempt to “run”
either the ECU+ Win or ECU+ Palm software while the vehicle is in motion.

 3 System Requirements
The ECU+ supports the following vehicles:

● 1990-1991 Mitsubishi Galant VR-4

● 1990-1994 Plymouth Laser, Mitsubishi Eclipse or Eagle Talon, AWD or FWD, turbo only

● 1995-1999 Mitsubishi Eclipse or Eagle Talon, AWD or FWD, turbo only

● 2003-2005 Mitsubishi Lancer Evolution VIII

The ECU+ head unit connects via a serial port to a Palm organizer and/or a laptop PC for
data display, logging and analysis.

The ECU+ Palm software, which runs on the Palm Organizer, requires Palm OS 3.5.1 or
later.  The Palm organizer itself must have a serial connection (“HotSync cable”) to connect to
the head unit.

The ECU+ Win software requires a Intel, AMD or compatible PC running  Windows 98, 98SE,
ME, 2000, or XP.  A Pentium II/366 Mhz or faster CPU is recommended.  If the PC is a
laptop, it can be used directly with the ECU+ head unit via a serial connection (be that a true
serial port, or a pseudo-serial port, like a USB-to-serial adapter).

If you have a laptop, you don't necessarily need the Palm organizer.  If not, you'll need a
separate PC to run the ECU+ Win analysis software.

 4 Packing List
When you purchased the ECU+, you should have received the following items:

● ECU+ head unit – this is the “black box.”  When shipped in the plug-n-play (PnP) version,
the head unit is pre-wired into a Field adapter harness.

● A software CD-ROM containing the ECU+ Windows and Palm software, as well as this
manual and other documentation.
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● Three wiring harnesses for connection to the car.  One harness will be a 2-pin cable, while
the two others will be 12-pin cables. These harnesses are not included in the plug-n-play
model.

● Wire ties.

● A 9-pin straight-through serial cable.  Male to female.  This is used to interface between
the ECU+ head unit and the laptop

● A null modem adapter, female to female.  This adapts the Palm organizer to the serial
cable.

 5 Head Unit Hardware Installation
The ECU+ “head unit” is the black box of the ECU+ system.  This device connects into your
car's wiring harness and intercepts various engine sensor signals.  The head unit  modifies
theses signals based on your inputs, and passes them on to the stock ECU. This section will
explain how to install the ECU+ head unit in your car.

 5.1 Tools Required

The ECU+ head unit can be installed by anyone with some basic electrical experience.  If you
can hook up a new car stereo, the ECU+ head unit installation will be a breeze.  To complete
the installation, you'll need the following tools:

● A set of common screwdrivers and a socket set (for removing the stock ECU).

● Wire cutters and a small knife.

● Electrical tape.

● A pencil-type soldering iron and solder.

● A simple multimeter for measuring voltages.

● Lots of patience.

 5.2 Wiring Basics

To install the non-PnP ECU+, you'll be splicing into the stock wiring harness that connects the
engine sensors to the stock ECU.  You'll make one of two types of connections: tapping or
splicing into the stock wiring harness.

 5.2.1 Tapping Wires

For most of the signals that the ECU+ head unit needs to see, you'll be strictly tapping into
the stock wiring harness.  That is, you won't be cutting the wires at all, but just stripping back
enough insulation so that you can “tap” the wire.  Here's what you'll do:

1. Strip about an inch of insulation from the stock ECU wire.

2. Strip an inch and a half of insulation from the end of the corresponding ECU+ wire.

3. Twist the bare ECU+ wire around the bare stock wire, then solder the two together to make
a solid connection.

4. Wrap this exposed connection with electrical tape.

Page 5



 5.2.2 Splicing Wires

A few of the ECU+ head unit connections require that you actually splice into the stock wiring
harness.  This involves cutting a wire in the stock harness and connecting a ECU+ wire to
either end.  To splice an end, follow these steps:

1. Cut the stock ECU wire with wire cutters.

2. Strip about an inch of insulation from the stock ECU wire.

3. Strip an inch of insulation from the end of the corresponding ECU+ wire.

4. Twist the two wires together and solder the connection.  The two wires will be a 'V' shape.

5. Bend the ECU+ wire backwards and wrap the exposed connection with electrical tape.

 5.2.3 Wiring Tips

– The stock wiring harness generally only exposes a few inches of wire from the stock ECU.
Try to make your connections about half-way between the stock ECU connector and where
it disappears under the dash.

– Make sure your hands are clean before wrapping the connection – even the slightest bit of
oil will foul the adhesive on the tape.

– Check and double-check that you're connecting the right wires before soldering.  It's much
easier to re-do a connection before soldering than after.

– A good online resource, including photos, for how to make these connections is at
http://www.mmxpress.com/technical/connections.htm

 5.3 Locating and Removing the Stock ECU

The procedure for removing the stock ECU is a function of the type of car you're installing the
ECU+ in.

For the Talon, Eclipse and Laser vehicles (all years), the stock ECU is mounted vertically and
is located behind the radio in the center console.  Remove both the driver and passenger kick
panels, and you'll find the ECU bolted in with three bolts.  Remove the bolts and the stock
ECU will slide out.  On the 1990-1994 cars, the stock ECU slides out on the passenger side.
On the 1995-1999 cars, it slides out on the driver's side.

For the Galant VR-4, the stock ECU is bolted underneath the dash on the far right side.
Remove the two bolts holding it in place, and it'll drop out.

For the Evolution VIII, the stock ECU is behind the glove box.  Remove the glove box (there's
a tab on the left side that'll free the glove box and allow it to drop out) and unbolt the two bolts
holding the stock ECU in place.  The stock ECU will drop straight down into the passenger
side floor.

 5.4 Making the Connections

With the stock ECU removed from your vehicle, it's time to do the hookup to the ECU+ wiring
harnesses.  All of the cars that the ECU+ supports have similar wiring, but the wire locations
on the stock ECU are different.
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 5.4.1 1990-1994 Galant VR-4, Laser Talon and Eclipse

On the 1990-1994 Talon, Eclipse, Laser and Galant VR-4, the stock ECU contains three
connectors, numbered as shown in Illustration 1.  This view shows the stock ECU as you'll
view it, facing the connectors.

To hook up the ECU+ head unit, you'll be wiring between the stock ECU and one of the three
ECU+ harnesses.  The ECU+ harnesses are identified by the connector type on the end:
power (the two-pin connector), digital (the rectangular 12-pin connector) and analog (the
larger, square 12-pin connector).

The analog and digital connectors each contain 12 wires, numbered 1-12, with the color
Page 7
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pattern [brown #1, black #1, red, orange, yellow, green, blue, violet, grey, white, brown #2
and black #2].  The brown and black #1 wires include a knot in the wire for identification
purposes.  When making connections, be careful to not mix up the brown/black #1 wires and
brown/black #2 wires, and also double-check which connector contains the digital and which
connector contains the analog connections.

The following tables show how the connections are done.

First, hook up the power harness for the ECU+.  This is the small two-pin connector.  Be very
careful here to not reverse the order of the connections.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Power (+12 volts) 102 Power 1 Red Tap

Ground 101 Power 2 Black Tap

Table 1 - The power connections

Next, hook up the analog connections.  This is the harness with the larger square connector
on it.  Note some things:

● The ECU+ analog connector is numbered in very small digits on the connector body.  Use
a flashlight to see the numbers.

● All of the connections here are taps.

● The black wire for the sensor ground is the second black wire, in the last hole of the
connector.

● The MAP sensor input supports the SenSym ASCX30 or GM 3-bar MAP sensors.

● If you have a supported wideband O2 sensor, hook it up to the spare 2 input.

● Spare 0 through 2 are extra analog inputs that support datalogging of any voltage source
between 0 and 5 volts.  Do not hook up any devices that produce voltages less than 0
volts or greater than 5 volts.  Doing so may damage the ECU+ head unit.
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Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Sensor Ground 17 Analog 12 Black #2 Tap

O2 Sensor 4 Analog 5 Yellow Tap

Throttle Position Sensor 19 Analog 7 Blue Tap

Air Temperature Sensor 8 Analog 6 Green Tap

Coolant Temperature Sensor 20 Analog 4 Orange Tap

MAP Sensor (optional) None Analog 1 Brown #1 Direct

Spare 0 Analog Input (optional) None Analog 2 Black #1 Direct

Spare 1 Analog Input (optional) None Analog 9 Grey Direct

Spare 2 Analog Input or Wideband
O2 sensor (optional)

None Analog 10 White Direct

Table 2 - The analog connections

Next hook up the tap digital connections.  The digital connector is the rectangular-shaped
connector with the latch on the top.  As with the analog connector, this connector is
numbered on the connector body.  Note that in the following table, both the brown and black
wires are the second brown and black wires on the connector.  The brown is in the next-to-
last connector location, the black is in the last.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Injector #1 51 Digital 11 Brown #2 Tap

Ignition Power Transistor #1/4 54 Digital 12 Black #2 Tap

Speed Sensor 18 Digital 7 Blue Tap

Table 3 - The digital tap connections

Finally, hook up the splice connections.  In each case, you'll cut the stock ECU wire, and
solder the sensor side to an ECU+ input wire, and solder the ECU+ output wire to the stock
ECU.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Mass Air Sensor (Sensor to ECU+)

Mass Air Sensor (ECU+ to ECU) 10

Digital 5 Yellow Splice

Digital 10 White Splice
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Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Crank Angle Sensor (Sens to ECU+)

Crank Angle Sensor (ECU+ to ECU) 21

Digital 9 Grey Splice

Digital 4 Orange Splice

Cam Angle Sensor (Sens to ECU+)

Cam Angle Sensor (ECU+ to ECU) 22

Digital 1 Brown #1 Splice

Digital 8 Violet Splice

Table 4 - The digital splice connections

Now skip to the section Finishing Up the Hardware Installation, on page 16.

 5.4.2 1995 and Up Talon, Eclipse and Evolution VIII, PnP ECU+

On the 1995-1999 Talon and Eclipses, and the Evolution VIII, the stock ECU contains four
connectors, numbered as shown in Illustration 3.  This view shows the stock ECU as you'll
view it, facing the connectors.  

To install the plug-n-play (PnP) version of the ECU+, simply unplug the stock connectors from
the stock ECU, and plug them into the mating connector on the ECU+ wiring harness.  The
ECU+ wiring harness contains a similar set of connectors – plug these into the stock ECU.
Each of the connectors are of different size – it's not possible to mix them up.

Next, you have to decide how to hook up the rear O2 sensor signal.  The ECU+ head unit has
a simulated rear O2 output for off-road use.  This signal simulates the signal that the stock
ECU will see from a functional rear O2 sensor.  If you've removed the catalytic converter from
your car, the rear O2 sensor signal from the sensor will often trigger a “Check Engine” light.
The ECU+'s simulated rear O2 signal can avoid that.  

To connect the simulated rear O2 signal, locate the wire from the ECU+ head unit containing
this signal.  Then locate pin #75 on the wiring harness, which is tapped with a red wire to the
ECU+ head unit.  Cut the harness wire between the male harness connector and where it
splices into the red wire, and solder in the simulated rear O2 signal to the wire containing the
splice.  See Illustration 6 for more detail.  If you're not using the simulated rear O2 sensor
signal, leave the ECU+ head unit wired as it is from the factory.

Lastly, hook up the optional remaining analog connections for a MAP sensor and/or the spare
analog inputs.  Note some things:

● All of the wires from the head unit are labelled as to their function.

● The MAP sensor input supports the SenSym ASCX30 or GM 3-bar MAP sensors.
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● If you have a supported wideband O2 sensor, hook it up to the spare 2 input.

● Spare 0 through 2 are extra analog inputs that support datalogging of any voltage source
between 0 and 5 volts.  Do not hook up any devices that produce voltages less than 0
volts or greater than 5 volts.  Doing so may damage the ECU+ head unit.

Each of these analog connections should be soldered directly to the appropriate input on the
ECU+ head unit.

Now skip to the next section, Finishing Up the Hardware Installation, on page 16.

 5.4.3 1995 and Up Talon, Eclipse and Evolution VIII, non-PnP ECU+

On the 1995-1999 Talon and Eclipses, and the Evolution VIII, the stock ECU contains four
connectors, numbered as shown in Illustration 4.  This view shows the stock ECU as you'll
view it, facing the connectors.  

To hook up the ECU+ head unit, you'll be wiring between the stock ECU and one of the four
ECU+ harnesses.  The ECU+ harnesses are identified by the connector type on the end:
power (the two-pin connector), digital (the rectangular 12-pin connector) and analog (the
larger, square 12-pin connector).  

Note: one ECU+ customer has observed that the four stock connectors are numbered, on the
connectors, backward from the numbering shown above.  Ignore these numbers and use the
numbering sequence shown above.
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The analog and digital connectors each contain 12 wires, numbered 1-12, with the color
pattern [brown #1, black #1, red, orange, yellow, green, blue, violet, grey, white, brown #2
and black #2].  The brown and black #1 wires include a knot in the wire for identification
purposes.  When making connections, be careful to not mix up the brown/black #1 wires and
brown/black #2 wires, and also double-check which connector contains the digital and which
connector contains the analog connections.

The following tables show how the connections are done.

First, hook up the power harness for the ECU+.  This is the small two-pin connector.  Be very
careful here to not reverse the order of the connections.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Power (+12 volts) 12 Power 1 Red Tap

Ground 13 Power 2 Black Tap

Table 5 - The power connections

Next, hook up the analog connections.  This is the harness with the larger square connector
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on it.  Note some things:

● The ECU+ analog connector is numbered in very small digits on the connector body.  Use
a flashlight to see the numbers.

● All of the connections here are taps.

● The black wire for the sensor ground is the second black wire, in the last hole of the
connector.

● The MAP sensor input supports the SenSym ASCX30 or GM 3-bar MAP sensors.

● If you have a supported wideband O2 sensor, hook it up to the spare 2 input.

● Spare 0 through 2 are extra analog inputs that support datalogging of any voltage source
between 0 and 5 volts.  Do not hook up any devices that produce voltages less than 0
volts or greater than 5 volts.  Doing so may damage the ECU+ head unit.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Sensor Ground 92 Analog 12 Black #2 Tap

Front O2 Sensor 76 Analog 5 Yellow Tap

Throttle Position Sensor 84 Analog 7 Blue Tap

Air Temperature Sensor 72 Analog 6 Green Tap

Coolant Temperature Sensor 83 Analog 4 Orange Tap

MAP Sensor (optional) None Analog 1 Brown #1 Direct

Spare 0 Analog Input (optional) None Analog 2 Black #1 Direct

Spare 1 Analog Input (optional) None Analog 9 Grey Direct

Spare 2 Analog Input or Wideband
O2 sensor (optional)

None Analog 10 White Direct

Table 6 - The analog connections

Next hook up the tap digital connections.  The digital connector is the rectangular-shaped
connector with the latch on the top.  As with the analog connector, this connector is
numbered on the connector body.  Note that in the following table, both the brown and black
wires are the second brown and black wires on the connector.  The brown is in the next-to-
last connector location, the black is in the last.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Injector #1 1 Digital 11 Brown #2 Tap

Ignition Power Transistor #1/4 10 Digital 12 Black #2 Tap

Speed Sensor 86 Digital 7 Blue Tap

Table 7 - The digital tap connections
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Next hook up the splice connections.  In each case, you'll cut the stock ECU wire, and solder
the sensor side to an ECU+ input wire, and solder the ECU+ output wire to the stock ECU.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Mass Air Sensor (Sensor to ECU+)

Mass Air Sensor (ECU+ to ECU) 90

Digital 5 Yellow Splice

Digital 10 White Splice

Crank Angle Sensor (Sens to ECU+)

Crank Angle Sensor (ECU+ to ECU) 89

Digital 9 Grey Splice

Digital 4 Orange Splice

Cam Angle Sensor (Sens to ECU+)

Cam Angle Sensor (ECU+ to ECU) 88

Digital 1 Brown #1 Splice

Digital 8 Violet Splice

Table 8 - The digital splice connections

Next, you have to decide how to hook up the rear O2 sensor signal.  The ECU+ head unit has
a simulated rear O2 output for off-road use.  This signal simulates the signal that the stock
ECU will see from a functional rear O2 sensor.  If you've removed the catalytic converter from
your car, the rear O2 sensor signal from the sensor will often trigger a “Check Engine” light.
The ECU+'s simulated rear O2 signal can avoid that.  Use one of the two tables below:

When using the simulated rear O2 signal, you'll cut the wire on pin 75 of the stock ECU, and
connect the ECU+ simulated rear O2 output to the pin 75 input of the stock ECU.
Additionally, you can connect this simulated rear O2 signal back into the ECU+ for monitoring
the signal that the ECU+ head unit is generating.

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Rear O2 Sensor (From Sensor)

Rear O2 Sensor (ECU+ to ECU)

Rear O2 Sensor (Monitor) 75

None

Analog

Analog

11

3

Brown #2

Red

Splice

Tap

Table 9 - The analog splice connections when using the simulated rear O2 signal

If you're not using the simulated rear O2 signal, just tap the rear O2 signal as shown below:

Function Stock
ECU
Pin # 

ECU+
Connector

ECU+
Pin #

ECU+ Wire
Color

Connectio
n Type

Rear O2 Sensor 75 Analog 3 Red Tap

Table 10 - The analog  tap connections when not using the simulated rear O2 signal
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When complete, installation into the 1995 and up Talon, Eclipse and Evolution VIII harness
should resemble Illustration 6 and Illustration 7 below, which shows the ECU+ connectors
wired into a Field CN-4 “patch harness.”  The top of the illustration shows the “plugs” from the
stock sensors which plug into the male connector on the stock ECU.
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Now skip to the next section, Finishing Up the Hardware Installation, on page 16.

 5.5 Finishing Up the Hardware Installation

When you're all done making the ECU+ connections, you'll have some unused wires in both
the analog and digital connectors.  Tie these wires together with wire ties and wrap them in
electrical tape.  Next, secure all three of the ECU+ harness wire bundles by applying wire ties
to each bundle.  In particular, be sure to use a wire tie very near each of the three connectors
– this will ensure that there's no stress on the pins in the cables.

Next, for the non-PnP ECU+, you'll want to verify that you've wired the ECU+ power correctly.
Using a voltmeter, hook up to the ECU+ two-pin power connection and turn your car's ignition
to the on position.  Your multimeter should read between positive 12 and 15 volts.  If not,
double-check your connections. With the wiring completed, you should plug the ECU+ head
unit into the newly-wired harnesses.

Page 16

Illustration 7 - Final installation, bottom view



Next, connect the included 9-pin serial cable to the appropriate connector on the ECU+ head
unit.

Before starting your car for the first time, install the ECU+ software and follow the instructions
in the next few sections to use either the Palm or the Windows software to setup the ECU+
head unit.  In particular, be sure that the cam and crank angle sensor types are set
appropriately for your car.  Once these are set correctly, turn off your ignition and leave it off
for a few seconds, then start your car.  It should run normally, just like it did before you
installed the ECU+.  If not, see the next section for troubleshooting information.

 5.6 Troubleshooting the Hardware Installation

In the previous section, you installed your ECU+ head unit.  Here are some things to check if
your car doesn't run normally after the install.

– For all problems, double- and triple-check the wiring.  Un-tape the connections and look at
them.  Is a good solder joint being made?  Are the wires connected according to the
tables?

– If your car won't start, chances are that either the cam or crank angle sensor signals aren't
working.  Verify that the head unit is using the proper signal type.  As a last resort, remove
the ECU+ head unit from its connectors and manually jumper together the cam and crank
sensor signals.

– If the car idles very fast and seems to be running rich, the MAS signal is probably not being
regenerated.  Again, check the wiring.  Does the software indicate that the input MAS
signal is 0 Hz?  If so, the MAS input may be disconnected.  If not, the MAS output may be
disconnected.

As a last resort, contact your ECU+ dealer and see what suggestions they might have.  The
ECU+ is tested at the factory, and should work for your car.

 6 Software Installation
The ECU+ system contains three pieces of software which need to be installed:

● The ECU+ Win software, which is a graphical Microsoft Windows-based display, tuning
and analysis tool.

● The ECU+ Palm software, which provides a graphical interface on your Palm device for
display and tuning of the ECU+ head unit.

● The ECU+ Palm conduit, which allows the Palm organizer to HotSync data between it and
your PC/laptop running ECU+ Win.

To install the software, insert the CD-ROM supplied with the system into your CD-ROM drive.
Then use the Windows Explorer tool to navigate to the CD-ROM, and double-click the
Setup.exe program.
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The ECU+'s text-based install will begin, and you'll be prompted for a directory to install the
software to.  Enter a suitable directory, and the installer will install the software for you.  You
should see a screen something like:
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The installer will install the Windows software (ECU+ Win) as well as the Palm conduit.  To
install the Palm software (ECU+ Palm), simply HotSync your palm with this computer and the
Palm software will be automatically installed on your Palm organizer.  Note: you may need to
restart the Palm Desktop software before starting the HotSync.

 7 Using the ECU+ Palm Software

 7.1 Introduction

The ECU+ Palm software interfaces to your ECU+ head unit and allows you to tune the
ECU+, perform a capture, or just monitor your engine's sensors.

 7.2 Starting the ECU+ Palm Software
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To start the ECU+ Palm software, tap its icon (see Illustration 10) on your Palm organizer.
This will start up the ECU+ Palm software, and display its initial screen (see Illustration 11).

 7.3 Changing Screens - The Button Bar

Using the ECU+ Palm software is simple.  The software includes four different screens which
allow you to display the engine's sensor values or tune the fuel and timing maps.  To switch
between screens, simply tap one of the four buttons along the top button bar (see Illustration
12).  Selecting '2' will select screen 2, selecting '3' will select screen 3, and so on.
Each screen serves a particular function:

 7.4 Screen 1
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Screen 1 is a general-purpose sensor display screen with large text.  Six sensor values are
displayed here, and the values shown are updated continuously.

To change which sensors are displayed here, tap the down-arrow button above a given value,
and select a new sensor (see Illustration 14).  The ECU+ Palm software will remember how
you've configured this (and other) screens between sessions.

The sensors that you can display are:

● MAS Input - This is the frequency of your MAS (mass-air sensor), as seen by the ECU+
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head unit, in Hz.  The MAS measures the amount of air entering your engine, where higher
frequencies indicate more air.  

● MAS Output - The frequency of the MAS sensor that the ECU+ sends on to your stock
ECU.  The stock ECU uses this value to determine how long to hold open the injectors, and
thus, how much fuel to supply to the engine. Higher output frequencies tell the stock ECU to
supply more fuel.  The MAS output frequency is the same as the MAS input frequency,
except as modified by the MAS adjustment and the injector scaling value.

● MAS Adjustment - The current adjustment to the MAS output frequency, as a percentage.
You configure the fuel maps that the ECU+ head unit uses, and the head unit changes the
MAS output frequency as you requested.  The MAS adjustment shows the current adjustment
that's in effect.  Note that the MAS adjustment doesn't include any inherent change in the
MASoutput frequency caused by the injector scaling value.

● Timing - The current engine timing, as a number of degrees.  The engine timing determines
where in the piston revolution that the spark plug fires, and is measured in degrees before or
after top-dead-center (TDC) of the piston.  This value is positive if the spark fires before TDC,
and negative if after.

● Timing Adjustment - As with the MAS Adjustment, this is the current timing adjustment (in
degrees) that the ECU+ head unit is using.  To adjust the engine timing, the ECU+ head unit
slides the cam and crank angle sensor signals of your engine forward or backward by a
specified number of degrees, and passes these modified signals on to the stock ECU.

● O2 Front - This is the reading of the front oxygen (O2) sensor in your car, in volts.  The front
oxygen sensor, normally located just beyond the turbocharger in the exhaust downpipe,
outputs a voltage roughly corresponding to how rich your engine is running.  Higher voltages
indicate a richer mixture (more fuel for every molecule of air) while lower voltages indicate a
leaner mixture (less fuel for every molecule of air).  This signal is typically between zero and 1
volt, and will switch back and forth between rich and lean when your car is idling or at part
throttle in normal driving situations.  Note: when O2 sensors get old or are failing, they often
have little or no output voltage, or are very "slow" to react to changes in fuel mixture.  Also, a
lack of voltage can indicate that the heater inside the O2 sensor is defective.

● O2 Rear - The voltage from the rear O2 sensor, if applicable.  The rear O2 sensor, when
installed, is on the far side of the catalytic converter (cat), and is often used by the stock ECU
to detect when the cat has been removed or is defective.  Removal of the cat will often trigger
a "check engine" light from the stock ECU.  Note that the ECU+ head unit can generate a
simulated version of this rear O2 sensor signal, which can be fed to the stock ECU to avoid
the check engine light.  This capability is for off-road  situations only. 

● Engine Speed - Your engine's speed, as a number of revolutions per minute (RPM).

● Air Temp - The temperature of the air entering your engine, in degrees fahrenheit, as
measured by the air temperature sensor.  The air temperature sensor is located in the air
intake, and is generally an integral part of the MAS.  This temperature readout here will
generally be a bit hotter than the true air temperature outside of your car.

● Coolant Temp - The temperature of the coolant in your engine, as measured by the coolant
temperature sensor.

● TPS - The voltage from your engine's throttle position sensor.  The TPS measures how far
you've pressed on the accelerator, as a voltage between zero and 5 volts.  The ECU+ head
unit considers a voltage above 4 volts to be wide-open-throttle (WOT), or below 0.75 volts to
be closed throttle.
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● Boost - Your turbocharger boost level, in pounds per square inch (PSI).  Note that this
reading requires an optional MAP sensor.  If you haven't installed a MAP sensor, this reading
will be zero.  Typically readings for a car at WOT will be 12-25 PSI, though this value varies
widely depending on your turbocharger.

● Inj Pulse Width - This is the pulse width, or on-time, of your engine's injectors, measured in
milliseconds (ms, or thousandth's of a second).  To squirt fuel into your engine, the stock
ECU turns on the injectors for a fraction of a second - the longer the injectors are on, the
more fuel is squirted.  This value will typically read out around 2 ms at idle, and much more at
WOT.

● Inj Duty Cycle - The "duty cycle," or ratio of on-time to total-time, for your engine's injectors.
This is displayed as a percentage.  The stock ECU has a fixed amount of time available to it
in which it can squirt the injectors.  This fixed time is inversely proportional to the engine RPM
(higher RPMs - less time).  The injector duty cycle measures what percentage of the total
time available that the injectors were on.  72% would indicate that the injectors were on 72%
of the time that was available.

● Vehicle Speed - This is the car's approximate speed, as measured by the vehicle's speed
sensor.  Note that this is an approximate value that is pretty close for stock vehicles.
However, changing tire or wheel size on your vehicle will affect the accuracy of this read-out.

● Spare 0, 1 and 2.  These are spare analog inputs to the ECU+ head unit that can be used
for any signal that ranges between zero and 5 volts.  The voltage displayed here is the
voltage of these spare inputs, and can be used for things like a wideband O2 sensor or EGT
(exhaust gas temperature) probe.  If you've hooked up a wideband O2 sensor to spare 2, this
value can instead display the vehicle's air/fuel ratio, where 10:1 is very rich, and 20:1 is very
lean.  

 7.5 Screen 2

Screen 2 is the catch-all sensor display screen.  This screen displays as many of the sensor
values as possible on one screen.  As with screen 1, the displayed values are updated
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continuously.  Tap the scroll bar on the right side to see the rest of sensor values. 

 7.6 Screen 3

Screen 3 is the graphing screen.  Two sensor values will be graphed here in real time.  As
with screen 1, which two sensors you'd like to graph can be selected by tapping the down-
arrow button on the text fields at the top.  At the bottom, two sets of buttons are available to
zoom in and out on a graph.  The first set of buttons is for the top graph, and the second set
of buttons is for the bottom graph.  For each, tap the '+' button to zoom in, and the '-' button to
zoom out.  Tap the up button to scroll the graph upward, or the down button to scroll the
graph downward.  Note that the ECU+ Palm software displays exactly 10 seconds worth of
data here in real-time - it's not possible to scroll backwards to see old data.

 7.7 Screen 4
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Screen 4 is the tuning screen.  Four sensor values are displayed and updated continuously.
In addition, you can use the top section of the screen to display and modify the fuel and
timing maps for your ECU+ head unit.  The head unit contains 33 fuel and 33 timing map
“cells”  which allow you control your engine's behaviour.  The fuel and timing map cells are
arranged as follows:

RPM Low Medium High WOT

Idle 0 Not used Not used Not used

1000 0 0 0 0

2000 0 0 0 0

3000 0 0 0 0

4000 0 0 0 0

5000 0 0 0 0

6000 0 0 0 0

7000 0 0 0 0

8000 0 0 0 0

Table 1 - The fuel table

There are 33 cells for both the fuel and timing maps - one for idle, and one each for low,
medium, and high loads, and one for wide-open-throttle (WOT) conditions.  Each of these
can be set individually - the fuel maps cell values can range from -50% to +50%, and the
timing map cell values can vary between -15 degrees and +15 degrees.

To configure a given load and RPM combination, tap the down arrow above the load value to
select a load, and tap the right or left buttons next to the RPM display to select the
combination you want.  Then tap the up or down buttons for the fuel or timing table entry you
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want to change.  Note that the left and right buttons next to the RPM display will cycle through
all of the load and RPM values in order - that is, keep tapping the right button to cycle through
all of the low load RPMs, then the medium load RPMs, and so on.

Screen 4 is particularly useful when tuning your car on a vehicle dyno.  You can set the
sensor displays to things that are useful for a dyno run, like RPM, front O2 voltage, air/fuel
ratio and engine timing, and then rev your engine to match a given RPM/load setting.  Then
adjust the fuel and timing settings to achieve the O2 voltage and engine timing that you
desire.

 7.8 The Menu Bar

The menu bar (see Illustration 18) provides access to the less common screens available in
the ECU+ Palm application.  To bring up the menu bar, tap the Palm's menu key.  From the
menu bar, various setup and help screens are available.

 7.8.1 The ECU+ Palm Setup Screen

The ECU+ Palm setup screen lets you configure several parameters related to the ECU+
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Palm application:

• Spare 2 Function – The spare 2 analog input can be used as a general-purpose 5 volt
input, or it can be hooked to a variety of wideband O2 sensors. Currently supported
wideband O2 sensors are:

• The PLX (http://www.plxdevices.com) M-200, M-250, M-300, M-400 and M-500
controllers.

• The FJO (http://www.fjoracing.com) Wideband AFR Analysis System.

• The Innovative Motorsports (http://www.innovativemotorsports.com) LM-1 Digital
Air/Fuel Meter.

• MAP Sensor Type – To display and capture boost, the ECU+ requires an external MAP
sensor.  Two map sensors are currently supported:

• The “GM 3-Bar” map sensor, available from any GM dealer.

• The SenSym ASCX30 two-bar map sensor, available from DigiKey
(http://www.digikey.com).

To change either of these parameters, tap the down arrow next to the value.  Tap the Done
button when you're finished.

Note that both of these parameters change how the ECU+ Palm application interprets the
spare 2 and boost voltages, respectively.  You'll need to make matching changes to the
ECU+ Win software.

 7.8.2 The Fuel Maps Setup Screen

The fuel maps setup screen (see Illustration 20) displays all 33 of the fuel map cells currently
in use by the ECU+ head unit.  To change a value, tap a cell value and use the Palm's grafitti
input to change the value.  When you're done, tap the Done button.
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 7.8.3 The Timing Maps Setup Screen

The timing maps setup screen works exactly like the fuel maps screen, but it modifies the
head unit's 33 timing maps instead of the fuel maps.  Tap Done to exit this screen.

 7.8.4 The Injector Scaling Setup Screen

Injector scaling allows the ECU+ to compensate for larger or smaller injectors, while giving
you the full -50% to 50% adjustment range in the fuel maps.  To use the injector scaling
feature, tap either the stock or current injector size field, and use the Palm's Grafitti input to
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enter a new injector size value.  From then on, the ECU+ will automatically scale the MAS
output to compensate for the injector ratio defined here.

Values between 420 cc and 780 cc can be entered here.

Tap the Done button to exit this screen.

 7.8.5 The Miscellaneous Setup Screen

The miscellaneous setup screen lets you configure various head unit parameters that don't fit
anywhere else.  The configuration values are as follows:

● MAS Freq Limit - This is the highest MAS output frequency that the ECU+ will generate on
its output.  This is used to limit the output MAS frequency to a given value, generally to avoid
fuel cut on your vehicle.  Tap the up or down arrows to change this value.  Note that due to
the limited precision of the ECU+ head unit, only certain frequencies can be set here.  Values
between 1000 and 2500 Hz can be set here.

● Input Cam Sensor - This sets the type of cam sensor used on your car.  Tap the down
arrow next to the type to set a new value.

● Output Cam Sensor - This sets the type of cam sensor that the ECU+ head unit should
generate.  As with the Input Cam Sensor type, tap the down arrow to set a new value.  Both
the input and output cam sensor types should generally match your car - this setting is
intended for those people using a different cam sensor than stock on their car.  Note that
when making changes to either cam sensor type, the ECU+ head unit must be power-cycled
for the setting to take effect.  Thus, to change either of these settings:

1. Turn your car off, and turn the ignition to its "ready to start the car" position.  In this
position, the ECU+ head unit is powered up but the car isn't running.

2. Tap the down arrow on the Palm to select the new sensor type.

3. Wait a few seconds for the ECU+ head unit to store the new value to its non-volatile
memory.
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4. Turn your car's ignition all the way off, and wait a few seconds.

5. Start your car.

● Firmware Version – This displays the current version of firmware running in your ECU+
head unit.

● Serial Number – This displays the serial number of your ECU+ head unit.

● MAS Bypass - This is a debugging option that forces the ECU+ to track your MAS sensor
signal with no changes.  This effectively causes your car's MAS sensor signal to pass
transparently through the ECU+ head unit.

● Cam/Crank Bypass - Similar to the MAS Bypass option, this forces your car's cam and
crank sensor signals to pass transparently through the ECU+ head unit.  Note that neither the
MAS Bypass nor the Cam/Crank Bypass check-boxes are remembered by the ECU+ head
unit - these are both switched off when the head unit is powered down, and have to be re-
enabled each time you start your car.

 7.8.6 The About Screen

The about screen displays the version number of the ECU+ Palm software.

 7.9 Capturing Data

The ECU+ Palm software can capture and store away "datalogging" information from the
ECU+ head unit.  These captures grab all of the engine sensor values 25 times per second
and store them away in a Palm "database" which can be viewed, or more importantly,
HotSync'd to a PC for use with the ECU+ Win software.

To start capturing data, tap the Capture button located at the bottom of each screen.  The
ECU+ Palm software will begin capturing data and display a status box that shows how many
seconds of data have been captured so far. 

Tap the Done button to save the captured data, or Cancel to discard it.  Note that the Palm
software saves captured data to a one-up database filename, which will match the filename
(with a .ecd extension) when this data is HotSync'd to a PC.

 7.10 Displaying Captured Data

The ECU+ Palm software contains a simple viewer for displaying captured data.  To invoke
the viewer, tap the Display button at the bottom of each screen.  This will invoke a display
data dialog in which you can display the contents of a capture.
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Tap the down arrow next to Select a File, and then select the database you'd like to display.
This will display the captured data in a simple columnar format, with a scroll bar that can be
used to move up and down in the data.  The viewer can display six sensor values (plus
elapsed time) at once, and you can select which columns you'd like to see by tapping the
Columns button and selecting the appropriate sensors.  As with all of the other ECU+ Palm
screens, your column selections will be remembered between sessions.  

Tap the Done button when you've finished viewing a database.

 7.11 Upgrading the ECU+ Palm Software

Occasionally, there will be updates to the ECU+ Palm software posted on the ECU+ web site.
To take advantage of these updates, download the software and extract the .zip file to a
temporary location on your laptop. You'll find a file called EcuPlusPalm.prc.  Drag and drop
this file into the Palm Desktop's Quick Install tool, and next time you HotSync your Palm with
your laptop, the new ECU+ Palm software will be automatically installed on your Palm.
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 7.12 HotSync'ing Captured Files to Your PC

When you do a capture  via the ECU+ Palm software, the captured data is stored in your
Palm as a Palm database.  These databases will be automatically transferred from the Palm
to your laptop whenever you do a HotSync operation.  If you've installed the Palm Desktop
software in the standard place on your laptop, you'll find these captured data files in the
directory:

  C:\Program Files\Palm\LastnameF

where LastnameF is your last name and first initial.

 8 Using the ECU+ Win Software

 8.1 Introduction

The ECU+ Win software, like the ECU+ Palm software, interfaces to your ECU+ head unit
and allows you to tune the ECU+, perform a capture, or just monitor your engine's sensors.
Unlike the Palm software, though, the ECU+ Win software also includes advanced data
analysis and display capabilities that allows you to easily and accurately configure the ECU+
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head unit to make your car perform at peak levels.

 8.2 Starting the ECU+ Win Software

To start the ECU+ Win software, double-click the icon on your desktop.

The ECU+ Win software should start up and display its main screen (see Illustration 28).  

Because of the amount of information that the ECU+ Win software can display, you might
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want to maximize the application.

 8.3 A Guided Tour of the Software

The ECU+ Win application is a relatively complex piece of software.  Let's take a look at it
one section at a time.

 8.3.1 The Menu Bar

The menu bar (see Illustration 29) is at the top of the screen, and includes the usual
Windows File, View, Help and other menu items.  The menu bar will change slightly
depending on what you are doing, but will always include File, View and Help.  The sub-
menus that are available on the menu bar are as follows:

 8.3.1.1 The File Menu

The file menu (see Illustration 30) is used to Open, Save, Close or Export a capture file, to
start a New capture, or to exit the ECU+ Win application.  You can also print the contents of a
graph (discussed later in this manual) from the file menu.  Depending upon what you're doing
with the ECU+ Win software, one or more of the items on the file menu may be greyed out or
not available.

The items on the file menu are as follows:

● New Capture - This connects to the ECU+ head unit and begins capturing data from it,
while displaying the data in real time.  This is equivalent to the Palm software's Capture
button.  Use this menu item to capture new data from your car.

● Open Existing Capture - This opens up an existing file on disk containing captured data,
and displays the data for viewing or analysis.  Use this menu item to display previously-
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captured data.

● Close Capture - When doing a new capture, this finishes the capture and prompts to save
the data to disk.  When viewing an existing capture, this closes the capture file and prompts
to save the data if it's changed.

● Save Capture - This saves any changes you've made to an open capture file, but doesn't
close the file.

● Export Capture - This allows you to export the currently open capture to a new file, in
comma-separated value (CSV) format.  You'll be prompted for the name of the new file.  CSV
is a common format that can be read by many applications.  Most often, you'll use a
spreadsheet program (like Microsoft Excel) to read a CSV file for complex analysis and
processing.

● Print - This prints the current graph view.

● Print Preview – Previews the graph view before printing.

● Print Setup - Lets you to configure your printer margins and other settings.

● Numbered files - The ECU+ Win software remembers the names of several recent capture
files that you've opened, and displays them with a number next to them.  Selecting a
numbered file opens that file quickly, without going through the Open Existing Capture menu
item.

● Exit - This exits the ECU+ Win application, and prompts to save any unsaved capture files.

 8.3.1.2 The View Menu

The view menu (see Illustration 31) allows you to toggle on and off the toolbar and status
bars for more on-screen real estate.  Simply select a menu item to toggle it on and off.

 8.3.1.3 The Window Menu
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The window menu (see Illustration 32) allows you to arrange the windows in the display area.
Cascade, Tile and Arrange Icons work as in other Windows software, but Auto Arrange is
unique, tiling the visible view windows in a sensible manner. The numbered windows on this
menu makes the selected window current (in front) and un-minimizes it if necessary.  The
More Windows dialog does the same thing, but is used when more than 9 windows are
shown in the display area.

Note that the Window menu will only be available when displaying an existing capture file or
capturing data to a new file.

 8.3.1.4 The Settings Menu

The Settings menu (see Illustration 33) allows you to configure the ECU+ Win software as
well as the ECU+ head unit.  Select either from the menu, and then follow the instructions
below for setting each up.

 8.3.1.5 The Help Menu

The Help menu has a single menu item which displays the About dialog for the ECU+ Win
application.  The about dialog just displays the software version and copyright information.

 8.3.2 The Toolbar
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The toolbar (see Illustration 34) is a quick way to access various ECU+ Win menu items with
just a single click.  The items on the toolbar, and the menu item equivalences are from left to
right:

● New Capture - The record icon.  This begins capturing data from the ECU+ head unit.  This
is equivalent to File->New Capture.

● Pause Capture - The pause icon.  This button temporarily pauses the current capture so
that you can scroll back and look at old data.  Click this button once to pause the capture,
and then again to restart the capture.  Any data received from the ECU+ head unit while the
capture is paused is lost.  There is no menu item equivalent to this button.

● Close Capture - The stop icon.  This closes a new capture or existing capture file, and
prompts to save the data if it's changed.  This is equivalent to File->Close Capture.

● Open Existing Capture - The open folder icon.  This opens an existing capture file for
analysys.  This is equivalent to File->Open Existing Capture.

● Save Capture - The floppy disk icon.  This manually saves the current capture if it's
changed.  This is equivalent to File->Save Capture.

● Setup Head Unit - The hammer icon.  This brings up the dialog box to configure the ECU+
head unit's fuel and timing maps, etc.  This is equivalent to Settings->ECU+ Head Unit.

● Add Overlay - The two-graph icon.  This adds a new overlay to the current capture file for
comparison purposes.  This is equivalent to Graph Context Menu->Overlaid Plots->Add New.

● Overlay Shifting - The next four icons (which show a graph and an arrow) are shortcuts
used for shifting the most recent overlay to the left or right.  The icons represent shifting left
1/4 page, left by one, shift right by one, and right by 1/4 page, respectively.  These are
equivalent to Graph Context Menu->Overlaid Plots->Shift Last.

● Graph Zooming - The next four icons (magnifying glass-like) are used to zoom a graph's X
or Y axis in or out, and are equivalent to Graph Context Menu->Zoom X(Y) Axis->In(Out).
They zoom the current graph out on the X axis, in on the X axis, out on the Y axis and in on
the Y axis, respectively.

● Dyno Analysis - The dyno icon.  This brings up the dyno analysis dialog.  This is equivalent
to Graph Context Menu->Analyze->Dyno Analysis.

● Help - The question mark icon.  Displays the current ECU+ Win “About" dialog.  This is
equivalent to Help->About ECU+ Win.

Note that the toolbar can be toggled on and off with the View->Toolbar menu item.  If you
never use the toolbar, you may want to turn it off.

 8.3.3 The Status Bar

The status bar (see Illustration 35) is used to display the settings of the keyboard caps-lock
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(CAP), num-lock (NUM) and scroll lock (SCRL) keys, as well as longer descriptions of menu
items.  The status line can be safely turned off with the View->Status Bar menu item.

 8.3.4 The Display Area

The display area makes up the bulk of the ECU+ Win's screen space.  Inside the display
area, the software will display “views” of a live or captured data file.  A view is just a sub-
window in which data is displayed.  Views will either be text boxes, containing data values
numberically, or graphs showing data in graph form.  More information on views is available
in section Setting Up Views on page .

 8.4 Creating a New Capture
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The ECU+ Win software can capture and store away "datalogging" information from the
ECU+ head unit.  These captures grab all of the engine sensor values 25 times per second
and store them away in a file on your computers hard disk.  This captured data can contains
a permanent record of your engine's operation, and can be later loaded back into the ECU+
Win software for analysis or comparison to other captures.

To create a new capture file, use the File->New Capture menu item, or click on the record
icon in the toolbar.  The ECU+ Win software will then open up the serial port and try to
connect to the ECU+ head unit.  Once the connection is established, the software will open
up the views that you've configured and begin capturing data from the head unit.  While the
capture is going on, you can open, close or resize any of the views in the display area.  At
any point during the capture, you can use File->Close or click the stop icon in the toolbar to
stop capturing.  When you stop capturing, ECU+ Win will prompt for you to save the file, and
display the standard Windows file-save dialog.  At any point during the capture, you can also
pause the capture by clicking the pause icon in the toolbar.  Any data accumulated from the
head unit while paused will be lost.

 8.5 Opening an Existing Capture File

Captures that you've aquired with either the ECU+ Win or the ECU+ Palm software can be
loaded into ECU+ Win by “opening” an existing capture file.  To do this, use either the File-
>Open Existing Capture menu item, or click the open folder icon on the toolbar and select the
capture file you'd like to view.  ECU+ Win will open this file and display its contents within the
views you've configured.  When you're done with this capture, use File->Close capture to
close it out.

Note: Only one capture file can be open at a time.  You can, however, overlay one capture on
top of another.  See the section Overlaying Multiple Capture Files on page 54 to see how this
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powerful technique works.

 8.6 Configuring the ECU+ Head Unit

You can use the ECU+ Win software to configure your ECU+ head unit's settings.  To start
the configuration dialog, either click the hammer icon in the toolbar, or use the Settings-
>ECU+ Head Unit menu item.  This opens the head unit configuration dialog, which has four
tabs for configuring the fuel maps, the timing maps, the injector scaling and other
miscellaneous values.  Let's take a look at them in turn:

 8.6.1 Setting Up the Fuel Maps

The fuel maps tab lets you configure the ECU+ head unit's fuel maps.  The fuel maps tell the
ECU+ head unit how to modify the engine's mass air sensor (MAS) signal.  To cause the
stock ECU to increase or decrease the fuel flow to your engine, the ECU+ head unit modifies
the MAS signal.  The MAS produces a frequency proportional to the amount of air entering
the engine.  By modifying the MAS signal, the ECU+ head unit “lies” to the stock ECU about
how much air is entering the engine, which causes the stock ECU to change its fuel flow
proportionally – less air means less fuel.

The fuel maps contain 33 different “cells” - one for idle, and 8 sets for low, medium, and high
engine “loads,” as well as 8 for wide-open throttle conditions.  Each cell represents how the
ECU+ head unit should modify the MAS frequency when the engine is running at that
particular load and RPM combination.

An example: let's say your car is accelerating at wide open throttle, and the engine is at 4000
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RPM, and the cell value for 4000 RPM/WOT is -10%.  If the engine's MAS frequency is 2200
Hz (representing some fixed amount of air flow), the ECU+ head unit will change this
frequency to 90% x 2200 Hz, or 1980 Hz, and pass this new frequency on to the stock ECU.
The stock ECU will then reduce the corresponding fuel flow by 10%, thus causing your car to
run 10% leaner at that RPM at WOT.

To set a given fuel map cell to a value, you can either type in a number into the appropriate
cell, or click the up and down arrows next to that cell.  You can also use the keyboard's up
and down arrows to increase or decrease the value in a cell.

Each fuel map cell can take on values from -50% to +50%, where negative numbers
decrease your engine's fuel flow (causing the engine to run leaner), and positive numbers
increase it (causing the engine to run richer).

Note that the ECU+ head unit interpolates values between the discrete levels in the fuel map
table.  That is, if your fuel map cell value is -10% at 6000 RPM and -12% at 7000 RPM, and
your engine is running at 6500 RPM, the ECU+ head unit will adjust the fuel by -11%.

The final option on the fuel maps dialog tells the ECU+ Win software to send fuel map
changes to the ECU+ head unit immediately.  If this isn't checked, values are only sent over
when you click “Ok.”

Within the fuel maps tab, you can load or save the maps from the ECU+ head to a file on
disk.  When saving maps, you're prompted for a filename only – both the fuel and timing
maps are always saved.  When loading maps, you'll be presented with this dialog:

You can select to load just the fuel maps, just the timing maps, or both.  By default, maps
stored on disk have the .ema file extension, though you can also retrieve the maps used in a
previous capture by specifying the .ecd capture file here.

 8.6.2 Setting Up the Timing Maps
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The timing maps tab lets you configure the ECU+ head unit's timing maps.  The timing maps
tell the ECU+ head unit how to modify the engine's cam and crank angle sensor signals.
When the ECU+ head unit modifies the cam and crank angle sensor signals, it causes the
stock ECU to fire the spark plugs either sooner or later than stock, thus affecting the engine
timing.

The timing maps contain the same 33 cells that the fuel maps do, corresponding to a given
engine load and RPM.  You can change the values with the keyboard or mouse, just as with
the fuel map values.  The timing maps specify a timing offset of between -15 and +15
degrees, where a positive value causes the spark to fire earlier in the engine cycle, and a
negative value causes a later spark.  Thus, positive values increase the engine's timing
advance, and negative values decrease the engine's timing advance.

As with the fuel maps, you can load and save sets of maps to disk from this tab.

 8.6.3 Injector Scaling Configuration
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The injector scaling tab allows the ECU+ to compensate for larger or smaller injectors, while
giving you the full -50% to 50% adjustment range in the fuel maps.  To use the injector
scaling feature, select a new injector size for either the stock or current injectors.  From then
on, the ECU+ will automatically scale the MAS output to compensate for the injector ratio
defined here.

Values between 420 cc and 780 cc can be entered here, and you can pick the values in from
the dropdown list, or type them in.
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 8.6.4 Miscellaneous Configuration

The miscellaneous settings tab lets you configure some random values in the ECU+ head
unit.  These are:

● MAS Output Freq Limit - This is the highest MAS output frequency that the ECU+ will
generate on its output.  This is used to limit the output MAS frequency to a given value,
generally to avoid fuel cut on your vehicle.  Type in a new number to change this value.
Note that due to the limited precision of the ECU+ head unit, only certain frequencies can
be set here.  Values between 1000 and 2500 Hz can be set here.

● Input Cam Sensor Type - This sets the type of cam sensor used on your car.  Click the
dropdown button next to the type to set a new value.

● Output Cam Sensor  Type - This sets the type of cam sensor that the ECU+ head unit
should generate.  As with the Input Cam Sensor type, click the dropdown arrow to set a
new value.  Both the input and output cam sensor types should generally match your car -
this setting is intended for those people using a different cam sensor than stock on their
car. Note that when making changes to either cam sensor type, the ECU+ head unit must
be power-cycled for the setting to take effect.  Thus, to change either of these settings:

1. Turn your car off, and turn the ignition to its "ready to start the car" position.  In this
position, the ECU+ head unit is powered up but the car isn't running.

2. Tap the down arrow on the Palm to select the new sensor type.

3. Wait a few seconds for the ECU+ head unit to store the new value to its non-volatile
memory.
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4. Turn your car's ignition all the way off, and wait a few seconds.

5. Start your car.

● Firmware Version – This displays the version of the firmware running in the ECU+ head
unit.  Use this when submitting bug reports.

● Serial Number – This displays the serial number of your ECU+ head unit.

● Force MAS Into Bypass Mode - This is a debugging option that forces the ECU+ to track
your MAS sensor signal with no changes.  This effectively causes your car's MAS sensor
signal to pass transparently through the ECU+ head unit.

● Force Cam/Crank Into Bypass Mode - Similar to the MAS Bypass option, this forces your
car's cam and crank sensor signals to pass transparently through the ECU+ head unit.
Note that neither the MAS Bypass nor the Cam/Crank Bypass check-boxes are
remembered by the ECU+ head unit - these are both switched off when the head unit is
powered down, and have to be re-enabled each time you start your car.

 8.7 Configuring the ECU+ Win Software

To configure the ECU+ Win software, use the Settings->ECU+ Win menu item.  This opens
the ECU+ Win configuration dialog.  As with the ECU+ head unit settings dialog, this one has
four tabs:

 8.7.1 View Configuration

The view configuration tab tells the ECU+ Win software what views you'd like to see by
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default.  When you start a new capture or open an existing capture file, the ECU+ Win
software starts up and displays one or more views of the data associated with this capture.  If
Remember which views were active is checked, the ECU+ Win software will display the same
set of views that were active the last time you showed a capture.  If this is un-checked, the
checked views will be shown instead,

The checkbox Remember window positions, sizes and zooms determines whether the ECU+
Win software will restore the views in the same window position, minimized status, and
overlap as before.

Lastly, the Initial plot time text field sets how many seconds the X axis of the graph views will
display by default.

 8.7.2 Notes Configuration

The Notes configuration tab allows you to configure which notes get added to new captures
by default.  When you start a new capture, the ECU+ Win software automatically copies the
values defined here into the notes view for that capture.  You can add or delete values from
this dialog to configure what notes are used by default.  If a field named “Date” and/or a field
named “Time” is defined here, it's filled in by the ECU+ Win software when the new capture is
started.

Double-click a field name or value to change it, and then press ENTER.
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 8.7.3 Communications Configuration

The communications configuration tab sets up what serial port your laptop will use when
talking to the ECU+ head unit.  Typical values used are COM1 (with a laptop that has a “real”
serial port), or COM5 (with a laptop using a USB-to-serial adapter).  Click the dropdown arrow
to change this value.

 8.7.4 Miscellaneous Configuration
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The miscellaneous configuration tab lets you configure several miscellaneous parameters: 

• Spare 2 Function – The spare 2 analog input can be used as a general-purpose 5 volt
input, or it can be hooked to a variety of wideband O2 sensors. Currently supported
wideband O2 sensors are:

• The PLX (http://www.plxdevices.com) M-200, M-250, M-300, M-400 and M-500
controllers.

• The FJO (http://www.fjoracing.com) Wideband AFR Analysis System.

• The Innovative Motorsports (http://www.innovativemotorsports.com) LM-1 Digital
Air/Fuel Meter.

• MAP Sensor Type – To display and capture boost, the ECU+ requires an external MAP
sensor.  Two map sensors are currently supported:

• The “GM 3-Bar” map sensor, available from any GM dealer.

• The SenSym ASCX30 two-bar map sensor, available from DigiKey
(http://www.digikey.com).

Click the dropdown for either of these to change the current values..

Note that both of these parameters change how the ECU+ Win software interprets the spare
2 and boost voltages, respectively.  You'll need to make matching changes to the ECU+ Win
software.
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 8.8 The About Dialog

The About dialog, accessible from the menu item Help->About ECU+ Win, displays the
version of the ECU+ Win software and a copyright notice.

 8.9 The Views

When displaying the contents of a captured data file, the ECU+ Win software opens up
multiple views of the data in the display section of the software.  There are several types of
views that the software can display.  Some views display several values, some are graphs
that can be scrolled around in, and some are just simple text displays.  Let's take a look at
them:

 8.9.1 The Engine Monitor View

The engine monitor view (see Illustration 47) is your one-stop shop for everything that the
ECU+ head unit knows about your engine's sensors.  It displays a variety of information about
the engine's sensors and what the head unit is doing.  When doing a new capture of live
data, the engine monitor displays the current data from the engine sensors in real time.
When viewing a capture file from disk, the contents of the engine monitor reflect the cursor
position on the current graph view.  Thus, the engine monitor displays the current engine data
at all times as a “snapshot” of what's going on.

Note: the engine monitor is the only view that can't be closed by clicking the 'X' in the upper
right of the window.

 8.9.2 The Notes View
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The notes view displays any notes associated with the current capture.  You can edit a note's
name or value by double-clicking on the field, making your change, and then pressing
ENTER.

 8.9.3 The Plot Color Legend View

The plot color legend view (see Illustration 54) is a simple box that shows what colors are
being used in the graph views when multiple files are overlaid.

 8.9.4 The Fuel Maps and Timing Maps Views

The fuel and timing maps can also be displayed in the ECU+ Win software's display area.
These views show the fuel and timing maps as they existed when the current capture was
made.  Additionally, the fuel or timing map value that corresponds to the current (new
capture) or cursor (existing capture file) data value is shown highlighted in this view.
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Remember that the ECU+ head unit interpolates between fuel or timing map cell values, so
this highlighted value doesn't necessarily reflect the exact fuel or timing offset that the ECU+
head unit is using – rather, it's the closest one.  So, for example, if your engine RPM is 3400
RPM, the 3000 RPM map cell will be highlighted, when in fact the ECU+ head unit is actually
using the value about half-way between 3000 and 4000 RPM.

 8.9.5 The Graph Views

The graph views are the most complex and powerful of the views to use.  A graph view shows
a single value from a capture in an X-Y plot, where the X axis is time, in seconds, and the Y
axis is the single value.  Graph views can be moved around, resized and zoomed.  Let's see
how these features work:

 8.9.5.1 The Cursor and Moving Around

The cursor in a graph view (shown as a small cross that tracks the graph) represents the
“current” spot on a graph.  When you hover your mouse over a graph view, the cursor tracks
the horizontal position of the mouse, and pops up a Windows tooltip showing you the current
X and Y axis values of the cursor on that graph.  If there are any other graph views displayed,
a similar tracking cursor is displayed which follows the mouse on all of the graphs at the
same time.  If you have a engine monitor view active, the values in the engine monitor
refelect the current cursor position.

To move the cursor around on a graph view, simply move the mouse.  If you'd like to see
other parts of the graph, you can use the X and Y scroll bars.  Note that the X axis of each
graph view is synchronized with the X axis of all of the other graph views.

 8.9.5.2 Zooming In And Out

Sometimes a graph view won't reflect exactly the X and Y ranges you'd like to see.  The
ECU+ Win software gives you multiple ways of zooming in and out:

● The keyboard shortcuts F8, Shift+F8 and Ctrl+F8 are configured to zoom the X axis in, out,
and to “full size” (as large as it can go), respectively.

● Similarly, F9, Shift+F9 and Ctrl+F9 zoom the Y axis.
● Other zoom options are available in the graph view Context menu (more on this in the next
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section).
● And last but not least, you can use the left mouse button to manually zoom to a specific

range – first, select the upper left corner, and press the left mouse button, then while
holding down the mouse, drag the dotted box to the lower right corner and release the
mouse.

 8.9.5.3 Using the Graph Context (RMB) Menu

Each graph view has what's called a “Context” or right-mouse-button menu, which you can
access by right-clicking on the graph.  This invokes a new menu:

The context menu has several items.  The first three items apply to the current graph only,
while the remaining options apply to the ECU+ Win software.  The menu items are as follows:

 8.9.5.3.1 Zoom X Axis and Zoom Y Axis

Use these menu items to zoom the X or Y axis of the graphs.  Any X axis changes applly to
all graphs, while any Y axis changes apply to the current graph only.  You can zoom each
axis in, out or to full size, or you can set the X and Y axis values to a specific size.  The Y axis
zoom has an additional option, “Fit Visible,” which will scale the Y axis to match the visible
data in that graph.

 8.9.5.3.2 Refresh

This menu item redraws the current graph.

 8.9.5.3.3 Auto Scroll

When capturing new data, this option is enabled.  With the option checked, new data will
cause all of the graph views to scroll rightward.  If you un-check the option, the graph will not
scroll with new data.  Compare this option to the pause icon – pause throws away new data
while keeping the graph stationary, while Auto Scroll keeps the graph stationary while
continuing to aquire new data.

 8.9.5.3.4 View and Window List

These menu items will be described in the section Setting Up Views on page .

 8.9.5.3.5 Overlaid Plots

This menu item will be discussed in the section Overlaying Multiple Capture Files on page 54.
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 8.9.5.3.6 Analyze

This menu item will be described in the section Analysis Tools on page 56.

 8.9.6 Setting Up Views

After starting a new capture or opening an existing capture file, the ECU+ Win software will
open a collection of views to show you the data associated with the capture.  Each view will
open in a window in the display area of the software.  You can then use the mouse or the
Windows minimize and maximize buttons to resize each window.  You best bet, though, is to
display the views you're interested in, and then use the Window->Auto Arrange menu item to
tile the windows.

If you've minimized a view window, or it's underneath another window and you can't see it,
you can use either the Window menu, and then select a window by number to show it, or
right-click on another window, and select Window List.

To close out a view window, click the 'X' in the window's upper right corner.  To display a new
view window, use the right-click context menu, and select View.  This will display a sub-menu
that looks like this:
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Click an item on this menu to activate or de-activate that view.  Views that are checked are
currently displayed, though they may be displayed in minimized view windows.

The key points to remember are:

● Use Context Menu->View to activate a view, or

● Use Window->Window List to un-minimize a view window or display it in front of the other
windows

 8.9.7 Overlaying Multiple Capture Files

When displaying a capture file, it's often handy to be able to view several capture files at the
same time for comparison.  The ECU+ Win software lets you do just that with the concept of
“overlaid plots.”  Here's how it works:

1. Open up an existing capture file, and arrange the view windows the way you like them.

2. Use the right-click context menu on one of the graphs, then select Overlaid Plots->Add
New.  The standard Windows file-open dialog will appear.  Select another capture file.

3. The ECU+ Win software will overlay this new capture directly on top of the original capture
file, using a different color for each capture on the graph.
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4. When you hover the mouse over the graph, the Windows tooltip will display the Y axis
values for all of the overlaid captures.  The current capture's value is in parenthesis.  You
can switch which capture is current with the TAB and shift-TAB keys.

5. Next use the “Shift Last” menu item (or the more-convenient “Align All for Dyno Analysis”
menu item) to align the two plots in time:

6. When you're all done, use the “Remove Last” menu item to remove the last capture from
the graph views.

Being able to overlay multiple captures is a very powerful technique to compare your vehicle's
performance before and after a hardware modification or when tuning your car's fuel and
timing via the ECU+ head unit.  In the next section, we'll see some more powerful techniques
with the Analysis Tools of the ECU+ Win software.
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 8.10 Analysis Tools

The ECU+ Win software offers two powerful analysis tools that will help you to tune your car
for best performance.  They are the Drag Race Analysis and the Dyno Analysis.

 8.10.1 Drag Race Analysis

You can access the drag race analysis from the graph view context menu as Analyze->As a
Drag Race.  What this analysis tool does is to treat the capture as though it was a run down a
¼ mile dragstrip, and calculates the elapsed time, vehicle MPH and distance 25 times a
second.  Additionally, it'll display typical drag race statistics, like 60' time and ¼ mile trap
speed.

To use this tool, select Analyze->As a Drag Race from the graph view context menu.  You'll
see a dialog like Illustration 57:

With the dialog visible, enter in the approximate start time of the drag race and click the
Calculate button.  The ECU+ Win software will try to find a spot past the start time in which
the car was over 60 MPH, and then search backwards to find the time when the car was
stopped.  It'll treat the stopped time as the start of the drag race and compute the vehicle's ¼
mile performance.

You can use the drag race analysis on a real dragstrip (or a deserted road) to see how your
car was doing at various points in the run, and to compare the car's performance before and
after a modification.
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Use the Add Summary to Notes button to remember the values calculated here.  This adds
the summary values to the notes view for this capture file.

Some considerations when using the drag analysis:

● The calculations use the vehicle's speed sensor, so if you've got non-stock gearing or tires,
the analysis may not match exactly what you'd get from a real dragstrip run.

● The calculations assume no tire spin, which is fairly accurate for AWD cars.  FWD cars will
be less accurate.

 8.10.2 Dyno Analysis

The dyno analysis tool, accessible from the graph context menu (Analyze->As a Dyno Pull) or
from the dyno icon on the toolbar, is perhaps the most useful tool in the ECU+ Win software.
What the dyno analysis tool does is to treat a short, single-gear acceleration as a dyno pass.
From the data in the capture file, ECU+ Win will calculate your engine's horsepower and
torque and plot it in an X-Y graph that can be zoomed or printed just like the other graph
views.  Here's how to use it:

1. Find a deserted back road where you can do some test runs.  The road should be flat and
straight.  You'll use a road sign or marker on the road as a “launch” spot.

2. Start a new capture on the ECU+ Win software.

3. Drive your car along the back road in 2nd (or 3rd, if you have access to a drag strip) gear,
and “lug” the car at the lowest possible RPM.  As soon as you pass the launch spot, floor
the accelerator and let the car accelerate to redline.  Then coast back down and pull off of
the road.

4. Stop the capture and save the file.  It may be useful to name the file so that you can easily
recognize it later (“20040301 Run3 – Boost at 19 PSI.ecd”).

5. Later at home, or after stopping the vehicle, open this new capture in the ECU+ Win
software, and manually zoom the X axis so that just the acceleration time is visible.  This
will be easy to find, as the TPS sensor will show the car at WOT, and pretty much
everything will be increasing with time.

6. Open the dyno analysis.  ECU+ Win will have filled in the start and stop times from your
zoomed graph.  Update the other inputs on the left side, and press the Calculate button.
The ECU+ Win software will now display your car's horsepower and torque graph, just as
though you had done a run on a real dyno.  See Illustration 59 for a sample graph.
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With the dyno analysis done, you can zoom the dyno graph with the mouse, or right-click for
a context menu that has the usual zoom capabilities.  You can also print the dyno analysis
with the File->Print menu item.  Use the Close button to close the dyno analysis.

The dyno analysis uses the engine's RPM to compute all of its results.  Because the vehicle's
speed (and thus acceleration, and thus torque and horsepower) is calculated based on the
car type, car weight, gear used, and tire size, it's important to set these parameters
consistently from one dyno run to the next in order to see reliable plots.

Some things to consider when doing a dyno analysis:

● The dyno analysis uses the Tranny Loss parameter to compute the engine's crank
horsepower from the measured (wheel) horsepower.  If you'd like to plot wheel
horsepower, put zero in this field.

● The Smoothing parameter smooths the engine RPM before doing the dyno calculation.
Larger numbers give smoother plots.  Generally, values in the 8-12 range work best.

● The ECU+ Win software will remember your dyno analysis parameters from one session to
the next, so it makes sense to put in the correct values for tire size and weight.

● When testing the effects of a performance modification (like a new air filter, or a change in
the fuel maps), it's important to do your “dyno runs” in similar weather, and always use the
same launch point on the road.

● You can overlay two or more captures, and then do a dyno analysis.  The dyno analysis
will show you the dyno results from each of the captures, all overlaid on the same dyno
plot.  This is incredibly useful when tuning your car.  The only caveat is that you must align
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the two overlaid graphs such that the dyno analysis time is the same for each.  As an
example, if graph 1 did a second gear acceleration starting at 32 seconds, and graph 2
started at 28 seconds, you'll need to move the second overlay to the right by 4 seconds.
Use the graph context menu item Overlaid Plots->Shift Last->Align For Dyno Analysis to
do this automatically.

● The dyno numbers are mathematically correct, but may not exactly reflect the numbers
that you'll get on a true vehicle dyno.  Nonetheless, what's important is not the absolute
horsepower and torque numbers, but instead that you can see whether changes you make
to your vehicle increase or decrease its performance.

 9 Tuning Your Engine With the ECU+
This section provides some general information on tuning your car with the ECU+.  Before
starting, please read and heed the following warning:

YOU CAN DESTROY YOUR ENGINE WITH THE ECU+!

Neither the manufacturer nor the distributor of this device are responsible for any
damage done to your vehicle due to the use of this device.

Always remember the above when tuning your vehicle.  If you're conservative when tuning,
you'll be able to use the ECU+ to make small, incremental improvements to your vehicle's
performance, and most important of all, not destroy your engine in the process.  It's
sometimes said that engines make maximum horsepower just before they blow up...

To avoid destroying your engine, keep in mind that an excessively lean mixture and timing
that is too-far advanced can lead to detonation.  Excessive detonation will destroy your
engine's internals.  So be very very careful when reducing fuel flow or advancing timing with
the ECU+ system.

 9.1 “Tools” Required

When tuning your car, you should have the following “tools” available:

1. The ECU+ system (of course), with the ECU+ Win software running on an in-car laptop.

2. A boost gauge, and possibly the ECU+ map sensor, wired into the system.

3. An Exhaust Gas Temperature (EGT) gauge.  This allows you to monitor your vehicle's
exhaust gas temperature.  Rapidly increasing EGT values

4. A wideband O2 sensor.  These are expensive, standalone boxes that can display your
vehicle's air-fuel ratio very accurately.  If this isn't available, the front O2 sensor in your
vehicle will make a (poor) substitute.

5. A friend to ride in the car with you.  Your friend will pilot the laptop while you pilot the car.
Note: please don't refer to your friend as a “tool” - he might not appreciate it.  :)

 9.2 Making Runs

The best way to tune with the ECU+ is to make a series of dyno runs.  See the section Dyno
Analysis on page .  You should select a flat, deserted road and make a series of runs, one
per capture file.  Between each run, make a single change in the fuel, timing or other
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parameters.  Then pull off the road and use the dyno analysis capabilities of the software to
compare the most recent run to the previous run and see how the horsepower and torque
curves compare.  This will tell you whether you're making adjustments in the right direction or
not.

You should start out by striving for consistency.  The same section of road.  Going WOT at
exactly the same RPM and launch point on the road.  The same dyno numbers and curves
when you don't change anything.  Once you've got a consistent set of dyno plots, change the
fuel, or timing, and make some more runs.  See if the car gained horsepower in a portion of
the graph, or if it lost horsepower.  Continue iterating until you've got the best performance
from your engine.

 9.3 General Tuning Techniques

● Before beginning tuning, setup the injector scaling values.  These establish a baseline fuel
offset for the injectors in your car.  

● You should start with a base set of fuel maps, and tune from there.  To determine the base
fuel maps, consider the size of your car's injectors as compared to stock, and determine
the base fuel maps from that.  Use the ratio of your current injector size to the stock
injector size as the base.  For example, if you have 550 cc injectors in your car now, and
the car came with 440 cc injectors, you should use a base map value of -20%.  That is,
you'll use (100%-20%) * (550 cc / 440 cc) to get back to 100%, or stock levels of fuel flow.

● With the injector scaling values in place, set all of the cells in the fuel and timing maps to
all zero.

● Tweak the idle fuel map cell for best idle.  You'll probably find that the larger the current
injector, the harder it is to achieve a smooth idle.

● On the road, make several runs with the fuel and timing maps set to zero.  Try to launch
your car from a roll consistenly so that the resultant dyno plots are almost identical.

● Next, make changes to the fuel maps for WOT conditions and do some more runs.  Power
is generally gained by reducing the fuel map values, thus making the engine run leaner.
From the factory, most cars run very rich at WOT, and the ECU+ allows you to
compensate for that.  For each change you make, make no more than a 2% change from
the last run.  Change one or two fuel map cells at a time.  When you bring the car to a
stop, you'll want to look at the front O2 voltage, which should be around 0.90 volts.  Also
look at the timing view and see how it compares to the previous run.  If you find that the
timing suddenly drops off at high RPMs, there's a good chance that the stock ECU heard
some knock from the motor.  This indicates that you're running too lean – fix that right
away.  Also, when you're doing the runs, always watch your EGT gauge for rapidly rising
temperature.  Again, this indicates an overly-lean condition.  If you have a wideband O2
sensor hooked up to the ECU+, use that for tuning.  Try to get your air/fuel ratios in the
12:1 range.

● Once you've optimized the WOT fuel tables, transfer the same values to the high load fuel
table cells.

● With the fuel table optimized, try tweaking the timing tables at WOT.  Make only 1 degree
timing changes between runs.  Generally, you'll want to advance the engine timing, thus
moving the spark time backwards so that it fires earier before top-dead-center (TDC) of the
piston.  This means putting positive numbers in the timing map cells.  As with the fuel
tables, make small changes and see what happens.
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 10 Troubleshooting Software Problems
This section provides some tips for diagnosing and fixing common software-related problems.

 10.1 ECU+ Win Problems

 10.1.1 The Software Never Connects

When I click on the “New Capture” button, a “Connecting” box  pops up that says
“Connecting to the ECU+ head unit...”, but a connection never happens.

To “connect,” the ECU+ Win software looks for a specific stream of data from the head unit.
Whenever the head unit is turned on, it transmits this stream of data.  If the ECU+ Win
software never sees the stream of data, it'll never “connect.” 

There are several things you'll want to check:

1. Is the ECU+ hooked up to the serial port?  You'll use the straight-through DB-9 serial port
to connect to your laptop.  Double-check the connections, ensuring that the serial cable is
secure and tightened down on both the ECU+ head unit and laptop end.

2. Are you connected to the serial port on your laptop.  On a laptop, serial ports are male DB-
9 connectors.

3. Does Windows recognize your serial port, and is it ok?  Bring up the Windows Device
Manager (usually under My Computer->Properties->Hardware->Device Manager).  You
should have a “Ports” entry for your serial port, and if you display its properties, Windows
should say “this device is working properly.”

4. Make sure the ECU+ Win software is using the correct serial port.

5. Make sure there are no hardware conflicts.  Sometimes Windows will “detect” a serial
mouse when none exists.  Manually disable these in the device manager.

6. Does the Palm software work ok?  If so, the head unit is fine.

7. Your car's ignition must be in the on (not accessory) position to power up the ECU+ head
unit.

As a last resort, you can use the HyperTerminal application to check to see if the ECU+ head
unit data stream is getting into your laptop.  Here's how:

1. Close down all applications.  Start HyperTerminal.

2. The "New Connection" dialog comes up first, type in "TestCom1" and then Ok.

3. On the next screen, set the "Connect using" field to COM1 (or whatever serial port you're
using) and then Ok.  Next a "COM1 Properties" dialog will come up.  Set  "Bits per second"
to19200, "Data bits" to 8, "Parity" to None, "Stop bits" to 1, and "Flow control" to None.
Then Ok.  

4. With the ignition in the on position , you should see junk streaming onto your
HyperTerminal screen.  At the bottom status line, it should say "Connected <time>  Auto
detect   19200 8-N-1".

If the HyperTerminal test shows data coming into your laptop, then the ECU+ Win application
should work..
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 10.1.2 Glitches

I sometimes get glitches on my capture files when using ECU+ Win, but there are no glitches
with the Palm software.  What's up?

The ECU+ Win application is a fairly CPU-intensive piece of software.  If your laptop is slow,
ECU+ Win may not be able to keep up with the incoming data stream.  This causes “glitches”
to appear in the captures.  There are several things you can do to improve this:

1. Close all other applications when doing a capture.

2. Don't resize or move windows while doing a capture.

3. Within ECU+ Win, try to keep the number of graph views to a minimum.  Redrawing the
graphs takes the most CPU time of anything in the ECU+ Win application.

4. Minimize the ECU+ Win application while doing a capture.

 10.1.3 Can't Open Serial Port

When I start a capture, ECU+ Win says it can't open the serial port.  What could be wrong?

There are several possible reasons for this error.  First, is the ECU+ Win software setup for
the correct serial port?  Step through the diagnosis in the section “The Software Never
Connects” first.  Once you've established that you have the correct serial port configuration,
check to see if some other device is using the serial port.  Often, the Palm desktop and
HotSync applications will take over the serial port.  Disable these applications and see if the
problem goes away.

 11 Support and Getting Help
Because the ECU+ system is a complex device, you may have problems with the software or
installation.  You have several lines of support open to you:

● For hardware installation problems, contact the dealer that you purchased the ECU+
system from.  They're best equipped to handle these type of problems.

● For software support, again your dealer is a good first place to start.

● For tuning help, your best bet is the forums at forums.ecuplus.com.  The forums are a
great place to hang out and learn about how others are using their ECU+.

● For any type of support, you also have the option of e-mailing the ECU+ developer – just
send an e-mail to support@ecuplus.com.  E-mails will generally be answered within 24
hours.

● If your ECU+ was working fine, but “breaks,” contact your dealer for information about their
return and repair policies.
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